What's new

Cubase Midi Recording ahead of the beat!! Whats going on?!

Polkasound

Senior Member
If you mean that you ALWAYS have messed up MIDI timing after recording it, I know about that issue as well as I had the same thing much earlier. I'm not sure how did I solve it but I would check the midi controller connection - if it's USB that might be the problem. Also those checking options in MIDI port Setup if you're on PC - ppl are saying that can help but I don't remember that ever helped me. But of 3 options to check I have :Use Device 'DirectMusic' checked only. In any case, you really shouldn't have this issue ever with the normal MIDI recording, it's very solvable.

It should be solvable, but I have checked, ticked, and adjusted everything in Cubase, ASIO driver, interface software, Windows, etc. in every combination which could affect timing, and not a single one will remedy the consistently early recording of MIDI. I researched the problem a few years ago and discovered it's a known-yet-unresolved issue affecting some PC users going back to the earlier days of Cubase.
 

Blakus

Midi Magician
Well, for those interested, I figured out what the problem was for me at least.

Edit -> Preferences -> Record -> MIDI -> ASIO Latency Compensation Active by Default
This will solve the problem for all future tracks. But for tracks that are already in a template, the only way I could find to do it was to enable the option on each track manually.

1. Go to 'Track Controls Settings' by right clicking

upload_2019-6-6_11-32-58.png

2. Make sure 'ASIO Latency Comp' is set as a visible control

upload_2019-6-6_11-35-52.png

3. It will now show up here, and needs to be activated (orange) on every track in your template

upload_2019-6-6_11-31-50.png

Good luck! I'm certainly happy to have found my solution anyway!
 

shomynik

Active Member
Well, for those interested, I figured out what the problem was for me at least.

Edit -> Preferences -> Record -> MIDI -> ASIO Latency Compensation Active by Default
This will solve the problem for all future tracks. But for tracks that are already in a template, the only way I could find to do it was to enable the option on each track manually.

1. Go to 'Track Controls Settings' by right clicking

View attachment 20535

2. Make sure 'ASIO Latency Comp' is set as a visible control

View attachment 20536

3. It will now show up here, and needs to be activated (orange) on every track in your template

View attachment 20534

Good luck! I'm certainly happy to have found my solution anyway!

Do you mean you fixed the timing issue with the Retrospective Recording? Or just the normal? I have activated ASIO Latency Compensation for all tracks, and normal recording works fine, just the Retrospective one still writes ahead of the beat around 15ms. This is the case with both C9.5 and 10.
 

TomaeusD

In Space
Well, for those interested, I figured out what the problem was for me at least.

Edit -> Preferences -> Record -> MIDI -> ASIO Latency Compensation Active by Default
This will solve the problem for all future tracks. But for tracks that are already in a template, the only way I could find to do it was to enable the option on each track manually.

1. Go to 'Track Controls Settings' by right clicking

View attachment 20535

2. Make sure 'ASIO Latency Comp' is set as a visible control

View attachment 20536

3. It will now show up here, and needs to be activated (orange) on every track in your template

View attachment 20534

Good luck! I'm certainly happy to have found my solution anyway!
Yup, this is exactly what I've been scouring the internet for. Thanks Blakus. Unfortunately @shomynik this is only for normal recording and doesn't affect retrospective recording. In those cases you will need to manually adjust the midi notes, I guess.

EDIT: I also wanted to note that the ASIO latency compensation only works for me when "Add Latency to MIDI-Thru Processing" is checked.
 
Last edited:

shomynik

Active Member
Yup, this is exactly what I've been scouring the internet for. Thanks Blakus. Unfortunately @shomynik this is only for normal recording and doesn't affect retrospective recording. In those cases you will need to manually adjust the midi notes, I guess.

EDIT: I also wanted to note that the ASIO latency compensation only works for me when "Add Latency to MIDI-Thru Processing" is checked.
Yep, I'm manually adjusting the notes all the freakin time unfortunately. :)
 

José Herring

Lost in Cyberspace
When you're playing with smaller latencys, you're usually ahead of time without noticing it. That's probably why the latency compensation helped you. Windows also has the problem with timing between the clock in the soundcard & motherboars which is the reason for the system time stamp option. I build a PC when this was unsolvable, I had midi jitters allover the place and nothing helped so I turned that PC into a slave and bought a mac instead.
Yes, when I first switched to Cubase PC from DP on Mac years ago this was a nightmare. Then the next update they came up with the system time stamp option and it fixed it (sort of).

What is odd to me is that Cubase has never really gotten midi timing right. It's still all over the place. It's livable with the time stamp on but I'm tired of always having to fix the timing after I play a line in. Total waste of time.

Were you ever able to get rock solid timing on the Mac?
 

drasticmeasures

(Formerly Nathan Furst)
Retrospective record IS INDEED a big blindspot in Cubase. Even things like auto quantize, lanes, etc don’t behave correctly with retrospective record. It’s a bummer.
 

KEM

The TENET Guy
Mine only records way ahead of the beat whenever my buffer size is really high, so I’ve always just attributed it to that
 

Simon Rigby

New Member
Hi all .. thank you for the help on this. Turning on ASIO Latency Compensation for instrument tracks has solved the issue. One thing to note is that it appears to fix for both standard record and retrospective record. Maybe this is a recent update. Unless I'm going nuts this appears to now work for both (PC).
 
Top Bottom