What's new

Cubase Midi Recording ahead of the beat!! Whats going on?!

JT3_Jon

Senior Member
Hopefully someone might be able to help as this is diving me CRAZY!

I'm working on a VST heavy midi project (like most here I'm sure) and it seems any new midi I add is being recorded almost a full 16th note earlier than I play it! So for example I'll record a drum part and while recording it sounds perfectly in time with the click and the rest of my tracks, yet when I playback the recorded track it will sound (and look) early against the grid, almost as much as a full 16th!! Cubase is somehow recording my midi earlier than its actually played, so (guessing here) it seems that the midi tracks are not following plugin delay compensation or something because its impossible to record something before its happens. But whats weird is this "early recording" happens both with "constrain Delay Compensation" on or off, using either instrument racks or tracks, both steinbergs own synths or 3rd party synths!

Here are my VST audio settings if it helps:
Input latency: 11.833ms
Output latency: 7.229ms
ASIO-Guard Latency: 0.000ms
HW Sample rate: 48k
HW Pull up/Down: Off
Audio priority: Normal
Multi processing: enabled
ASIO-GUARD: not enabled
Disk Preload: 2 seconds
Adjust for record latency: not enabled

Cubase 7.5.2 OS10.8.5 MacPro 8-core 2.93Ghz, 32GB RAM, UA Apollo running at a buffer of 256. I am using VE pro for some (not all tracks) but like I said this happens both with cubases own synths running as an instrument directly in Cubase.

When I play any midi notes, I do not hear any noticeable latency between when I press the key and when I hear the sound, so its not like I'm trying to compensate for a large buffer size when recording, and even if I was that would cause the midi to be recorded late, not early correct? Could this have anything to do with Cubase plugin delay compensation? Like I said, I've tried recording with both "constrain Delay Compensation" on and off and it doesn't seem to make a difference.

Any hep would be GREATLY appreciated as this is really becoming a problem!! Thanks in advance for any help you can provide. What sucks is I can load a blank cubase project and not seem to get this problem, which makes me wonder if perhaps one of my plugins is causing the problem. But before I go stripping all my plugins and thereby running my project, maybe someone has any advice on other things to try?
 
OP
JT3_Jon

JT3_Jon

Senior Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #4
Thank you snattack and GP_Hawk for your help!! Turning on the "AISO Latency Compensation" button in the track seems to have solved the problem! Is there any reason not to have this button enabled on every track I create? BTW there is a way to have it on by default - its in the preferences under Record - MIDI and called "AISO Latency Compensation Active by Default, incase anyone else needs this in the future.

Thanks again!!

edit: spoke too soon! It seems the AISO Latency compensation button only works when you record with record mode, and I personally always use retrospective record for my midi. DARN!!! :(

edit 2: I cannot seem to find this "use system timestamp" option in the manual anywhere. Any idea where it is located? Is it a preference? I've looked in my devices -> Device setup -> Midi Port setup and I do not see this option anywhere.
 

rayinstirling

Senior Member
I've searched the net for a fix to no avail. If you're adding midi realtime to an arrangement it will be early but everything is so you just move it.
Yes! I have tried the timestamp thingy.
 
OP
JT3_Jon

JT3_Jon

Senior Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #6
I've searched the net for a fix to no avail. If you're adding midi realtime to an arrangement it will be early but everything is so you just move it.
Yes! I have tried the timestamp thingy.

Turns out the timestamp setting is windows only. I'm on a mac.

Whats odd is the AISO Latency Compensation switch does work if I record using the record button, but I often jam along and use retrospective record to capture something if its works, and for whatever reason when I use retrospective record its capturing it early, as if I had the AISO Latency Compensation off! I'm going to email steinberg and see if its a bug.
 

GP_Hawk

Member
Oh shoot, didnt pay attention to the fact you are on osx! Sorry...any luck figuring it out? I have an mac with osx but I only use logic on that machine.
 
OP
JT3_Jon

JT3_Jon

Senior Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #8
no problem. Unfortunately support hasn't been that helpful yet, but I hold out hope we can figure it out.
 

snattack

Senior Member
When you're playing with smaller latencys, you're usually ahead of time without noticing it. That's probably why the latency compensation helped you. Windows also has the problem with timing between the clock in the soundcard & motherboars which is the reason for the system time stamp option. I build a PC when this was unsolvable, I had midi jitters allover the place and nothing helped so I turned that PC into a slave and bought a mac instead.
 
OP
JT3_Jon

JT3_Jon

Senior Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #10
This is starting to look more and more like a bug. I can confirm this behavior by recording (with AISO Latency compensation on) and then when its done ALSO capture the track as recording (so its captured the exact same recording). The captured midi will jump ahead of the recorded midi, which in theory they should double exactly, right?[/i]
 

mingin

New Member
Hello, i have exactly the same problem since years and i tryed so many many stuff. Nothing works. So i checked out the miliseconds and created a new click sound with the exact miliseconds of silence in front of it. Now the click comes a little bit later and i play exactly on the bars. Not a perfect solution, but it works.
Good luck!

By the way... I had the same problem on mac and pc.
The steinberg support never answered me!
 

shomynik

Active Member
Sorry for resurrecting this thread but I'm really hoping that someone finally found a fix for this. It's very hard to nudge a bit into place after a recording, especially when you really liked the groove that you just performed.

I'm on the v9.5 now but had the same problem on earlier versions as well.

Anyone?
 

Buddy

Member
Sorry for resurrecting this thread but I'm really hoping that someone finally found a fix for this. It's very hard to nudge a bit into place after a recording, especially when you really liked the groove that you just performed.

I'm on the v9.5 now but had the same problem on earlier versions as well.

Anyone?

This has been annoying me for years. I was beginning to think it was all in my head. Weird sort of comfort knowing I'm not alone
 

Pietro

Senior Member
This happens if you are using insert plugins that introduce latency. Especially on master bus. Like Ozone (100-300ms!).

I subconsciously learned to play ahead so it sounds in time. Cubase is registering that as early (cause it is). To a point, that in an empty project at low latency when I play I feel the sounds is playing before I actually hit the keys. So weird.

Latency compensation on tracks helps, but most importantly, try to avoid high latency plugins when composing.

In Cubase 10 mixer there is a latency indicator on every track.

- Piotr
 

Polkasound

Senior Member
I've been dealing with this for five years now, ever since Cubase 7. My instrument tracks record MIDI data about 30ms ahead of the beat. Audio records right on the beat, but MIDI records early, which can only mean there is something in Cubase compensating for some sort of latency. I've tried every setting and every solution suggested, and not a single one works. Whatever Cubase is doing, I can't shut it off.

I've simply learned to cope with it. Before I start recording an instrument track, I shift the track's timing to a delay of 30ms so that it sounds like it's in time with the music. When I get the track finished, I bounce all the MIDI together, make sure the snapping feature is off, zoom in and manually slide the part to the right until the downbeats line up with the bars, reset my track's timing, and apply any quantization as needed.

If I need to re-record a part in a finished track, I do my best to play behind the beat. Then I go back in and manually slide the notes over about 30ms and quantize as needed.

Cubase has been aware of this problem from the very beginning. What they need is an "Automatically delay recorded MIDI data by ____ ms" feature. That would make my life sooooo much easier.
 

shomynik

Active Member
This happens if you are using insert plugins that introduce latency. Especially on master bus. Like Ozone (100-300ms!).

I subconsciously learned to play ahead so it sounds in time. Cubase is registering that as early (cause it is). To a point, that in an empty project at low latency when I play I feel the sounds is playing before I actually hit the keys. So weird.

Latency compensation on tracks helps, but most importantly, try to avoid high latency plugins when composing.

In Cubase 10 mixer there is a latency indicator on every track.

- Piotr

That is unfortunately not the case here, beside the fact that I don't have active any of the latency introducing plugins while composing, there is also a fact that notes are recorded "in time" exactly as there were played in when they are recorded in conventional way by pressing RECORD. And here we are having a problem with the Retrospective Record only, which for some reason records notes ahead of time. Logically, they should have the same result, right? Unfortunately, they don't.


I've been dealing with this for five years now, ever since Cubase 7. My instrument tracks record MIDI data about 30ms ahead of the beat. Audio records right on the beat, but MIDI records early, which can only mean there is something in Cubase compensating for some sort of latency. I've tried every setting and every solution suggested, and not a single one works. Whatever Cubase is doing, I can't shut it off.

I've simply learned to cope with it. Before I start recording an instrument track, I shift the track's timing to a delay of 30ms so that it sounds like it's in time with the music. When I get the track finished, I bounce all the MIDI together, make sure the snapping feature is off, zoom in and manually slide the part to the right until the downbeats line up with the bars, reset my track's timing, and apply any quantization as needed.

If I need to re-record a part in a finished track, I do my best to play behind the beat. Then I go back in and manually slide the notes over about 30ms and quantize as needed.

Cubase has been aware of this problem from the very beginning. What they need is an "Automatically delay recorded MIDI data by ____ ms" feature. That would make my life sooooo much easier.

If you mean that you ALWAYS have messed up MIDI timing after recording it, I know about that issue as well as I had the same thing much earlier. I'm not sure how did I solve it but I would check the midi controller connection - if it's USB that might be the problem. Also those checking options in MIDI port Setup if you're on PC - ppl are saying that can help but I don't remember that ever helped me. But of 3 options to check I have :Use Device 'DirectMusic' checked only.

In any case, you really shouldn't have this issue ever with the normal MIDI recording, it's very solvable.
 
Last edited:

shomynik

Active Member
On the VST audio system of studio setup it shows your input and output latency.
add them up, times by 100 and add to the Record Shift field at the bottom of the same setup screen.

Just tested that and I can't make it to do anything, not getting ANY effect with it. Tried with different numbers including the 100000 and -100000 (it seems those are the limits), and those are supposed to be full seconds plus and minus. Wonder what am I missing.
 

shomynik

Active Member
Do you have "Use System Timestamp" ticked? Or are you on a Mac?
No, no "Use System Timestamp" ticked, just "Use Device 'DirectMusic'" ticked. It's the RME midi driver, I think.

But I do have two other options, not ticked:

"Use System Timestamp for Windows MIDI" inputs"
and
"Use System Timestamp for DirectMusic" inputs"

I'm on PC.
 
Last edited:

shomynik

Active Member
Try them both, think it was Windows MIDI for me (not at workstation right now).

Ok, thank you. But, do you think this would sort the Retrospective Recording specifically, or you just referring to regular recording as well?

BC I don't have any problems with normal recording.
 

Pietro

Senior Member
Regarding recording vs retrospective recording. The latter doesn't seem to have delay compensation and is indeed coming out twice as early :P.

- Piotr
 
Top Bottom